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Inleiding
Dit document geeft een introductie hoe je virtuele robots kunt simuleren in een mooie 3D omgeving
met de naam webots. De software voor de webots omgeving is open source en goed 
gedocumenteerd. Het is niet de meest eenvoudige omgeving maar biedt alle mogelijkheden om 
realistisch je robot vorm te geven in zelf gemaakte omgeving. Je kunt deze robot via je eigen 
programma code besturen en het is zelfs mogelijk om meerdere robots tegelijk binnen je omgeving 
samen te laten werken. De robots kunnen tegen objecten opbotsen en dingen oppakken en 
verplaatsen. Ook is een uitgebreide verzameling sensoren beschikbaar die je virtueel op je robot 
kunt plakken. Zo kun je bijvoorbeeld met afstandsensoren werken, virtuele camera's op je robot 
zetten of werken met een lidar. Je kunt zo ideeen uitproberen die met een eigen robot lastig zou 
kunnen realiseren vanwege de schaal of financiering. Ook is het mogelijk om in een simulatie je 
software te ontwikkelen voor een robot waar je geen eigen testomgeving voor hebt.
En het maken en laten lopen van virtuele robots is fun :-).

In dit document wordt met '<gebruikersnaam>' je eigen inlognaam aangegeven in voorbeeld paden 
naar directories en dergelijke. 

Webots installeren
De webots software draait op Windows, macOS en op Linux de Ubuntu versie. Deze handleiding 
gaat uit van een installatie op een windows platform maar de verschillen met de andere installaties 
zullen minimaal zijn. 

Om webots te installeren volg je de volgende stappen:
– Ga met je webbrowser naar deze url: https://www.cyberbotics.com
– Klik op de download button en bewaar het bestand 'webots-R2021a_setup.exe' op je pc in 

een eigen directory door op de 'Save File' button te klikken.
– Standaard op windows komt deze file in je Downloads directory terecht, ga daar naartoe.
– Dubbelklik op het bestand 'webots-R2021a_setup.exe' om de installatie te starten.

– Bij bovenstaand venster kies je voor de aangegeven optie.
– Met deze keuze komt de webots software in de volgende directory: 

'C:\Users\<gebruikersnaam>\AppData\Local\Programs\Webots'
– Klik op 'next' en 'ok' totdat de installatie gedaan is.
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Probeer of je webots kunt opstarten door in de windows search bar 'webots' in te tikken, kies dan de 
webots app die dan verschijnt. De app heeft een klein kevertje als icoon :

Je zou nu een venster moeten zien met de webots ontwikkelomgeving.

De webots scherm indeling
Om thuis te geraken in webots gaan we een voorbeeld webots project bekijken. 

– Start webots op.
– Kies 'File->Open Sample World->vehicles->boomer.wbt'.

Webots laadt nu de boomer.wbt wereld met daarin een voorlopig vliegende tractor :-).

Het scherm bestaat uit drie hoofddelen. Links staat een lijst met componenten die bij elkaar de 
volledige simulatie beschrijven. Elke component heeft een bepaald doel. Zo heeft de 
TextureBackground in deze lijst de parameters voor de achtergrond in de verte die bergen laat zien.
Het middenscherm geeft een 3D beeld weer. In dit voorbeeld staat een zwart vlak, dat het beeld dat 
door de camera van de robot wordt opgehaald en getoond. Momenteel staat de camera uit dus is er 
geen beeld. Verder is het robot model zichtbaar. In dit geval dus een robot tracktor die aan het begin
van de simulatie nog in de lucht hangt maar zodra de simulatie gaat lopen naar het veld getrokken 
zal worden.
Ook de grond is en dergelijke is onderdeel van de simulatie en kan aangepast worden. In dit 
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voorbeeld is het een vlak met een zich herhalend patroon van een droog grasland.
In het rechtervlak van het scherm bevindt zich de besturingscode van de robot, de controller. Door 
zelf hiervoor de code aan te passen kun je sensoren uitlezen op de robot en acties uitvoeren op de 
robot. Bijvoorbeeld de afstandssensoren lezen en de motoren op snelheid brengen. Ook is het 
mogelijk een motor in een bepaald positie te zetten, bijvoorbeeld om een stuur van een robot in een 
bepaalde stand te zetten.

Het 3D model bekijken
Het midden scherm bevat het 3D model. Je kunt de volgende acties hierin uitvoeren met je muis:

– Het 3D model draaien; klik op de linker muisknop en hou die vast terwijl je de muis 
beweegt. Je draait nu om het huidig geselecteerde model.

– Het 3D model verplaatsen; klik de rechter muisknop en hou die vast terwijl je de muis 
beweegt. Je verplaatst nu het beeld naar link, rechts, boven of onder.

– Selecteer een object; door te klikken met de linker muisknop op een object wordt het 
geselecteerd. Het krijgt dan rode, groene en blauwe pijlen. Door op een pijl te klikken en die
vast te houden kun je het object zelf verplaatsen. Verder kun je door op de ronddraaiende 
pijlen te klikken het object draaien in de x, y of z as.

Het is handig om het assenstelsel zichtbaar te maken in het midden scherm. Ga hiervoor naar 'View-
>Optional Rendering->Show coordinate system'. Je krijgt dan gekleurd assenstelsel te zien rechts 
onderin het middenscherm.

Wat hierbij opvalt is dat de X en  Z as horizontaal in de wereld staan terwijl de Y as naar de hemel 
wijst. Dit in tegenstelling tot wat vaak binnen de wiskunde op school wordt gedaan waarbij de Z as 
naar boven wijst.
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Het simulatie detail niveau aanpassen
Mocht tijdens het draaien van de simulatie het beeld niet vloeiend bewegen of traag verlopen dan 
heeft mogelijk je video kaart niet genoeg snelheid voor het laten zien van alle details van de 
simulatie. Dit zijn details als hoge resolutie textures, schaduwen etc.
Om dit op te lossen:

– Ga naar 'Tools->Settings'
– Kies tab 'OpenGL'
– Zet de settings als volgt:

Bij het laten lopen van de simulatie zullen nu een paar details zoals schaduwen ontbreken maar de 
simulatie zal vloeiender verlopen.

Het bewaren en ophalen van je simulatie
Het is van belang om regelmatig je simulatie op te slaan op je harddisk. Om dit te doen gebruik je 
de Laad (links) en Save (rechts) iconen in de iconen balk: 

Een bijzonderheid is hierbij dat als je de simulatie opslaat dat dan de simulatie in de toestand van 
dat moment wordt bewaard. Als je dus net de simulatie hebt laten lopen dan zal de volgende 
waarschuwing verschijnen:
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Vaak is dit niet wat je wilt omdat je bij het inladen vanaf het begin van de simulatie wilt werken. 
Dus klik eerst op het 'Reset simulation' icoon in de lijst met iconen bovenaan je scherm: 

Daarna kun je het Save icoon gebruiken om je simulatie netjes op te slaan op de harddisk.

De simulatie tijdsbalk
De simulatie van een robot verloopt als een soort film in de tijd. Zodra je de simulatie start begint 
de simulatie-tijd te lopen. Dit wordt getoond in het tijdsveld:

Links staat hoelang de simulatie heeft gelopen. Rechts staat een getal dat aangeeft hoe dicht de 
simulatie de echte tijd heeft weten bij te houden. Als de waarde structureel lager dan 1 is dan heeft 
de simulator het te druk om op tijd alles uit te voeren. Met de huidige snelle systemen zou dat niet 
snel gebeuren.

De simulatie besturen en een film maken

De volgende iconen besturen de simulatie.
Spoel de simulatie terug naar het begin van de 
simulatie-tijd.

Voer 1 enkele stap van de simulatie uit.

Start de simulatie en laat die lopen in echte tijd.

Laat de simulatie zo snel mogelijk lopen in 
versnelde tijd.
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Start het maken van een film van de simulatie. 
Druk op de stop opname 

Het opnemen van de film loopt. Klik op dit 
icoon om de film opname te stoppen.

De Virtuele Roborama basis projecten
Binnen de HCC Roborama zijn drie hoofdonderdelen te vinden. Dit zijn het lijnvolgen, de mini-
sumo wedstrijden en wedstrijden in de T-Track wedstrijdbak.
Al deze onderdelen zijn beschikbaar in de virtuele webots omgeving door ze van de Github website 
op te halen. Voer de volgende acties uit om ze eenmalig op te halen en naar je eigen systeem te 
krijgen:

– Open je webbrowser en ga naar : https://github.com/roboticas/virtual
– Klik op de groene 'Code' button en kies 'Download ZIP'
– Kies 'Save file' en een directory op je eigen systeem.
– Nadat het downloaden van de zip file gebeurd is ga je naar de directory op je eigen systeem 

waar de zip file 'virtual-main.zip' staat.
– Dubbel-klik hierop. Je ziet nu de inhoud van de zipfile, dit is de 'virtual-main' directory.
– Dubbel-klik op de 'virtual-main' directory.
– Dubbel klik op de 'world' directory/
– Op je toetsenbord gebruik je nu de combinatie 'Ctrl' toets en 'A' tegelijk om alle files te 

selecteren:

– Gebruik de toetsencombinatie 'Ctrl' toets en tegelijk 'C' om deze files te copieren.
– Ga naar de 'Documents->webots' directory en gebruik de toetsencombinatie 'Ctrl' toets en 

tegelijk de 'V' toets om deze files naar deze directory te copieren.
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Hiermee heb je de verschillende basis projecten beschikbaar gemaakt voor gebruik binnen de 
webots simulatie omgeving.

Het opstarten van de webots omgeving
Om de webots simulatie omgeving op te starten onder windows ga je naar de taakbalk onderin je 
scherm en tik je in de zoekbalk daar 'webots' in.
Het volgende scherm verschijnt:

Klik op de blauwe balk met het kevertje om webots te starten :-).

Een simulatie laden
Als voorbeeld gaan we nu de lijnvolger simulatie inladen en die laten lopen binnen webots.

– Ga naar 'File->Open World...'
– Kies dan:
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– Klik op 'Open'.
– Na een paar seconden zie je het webots scherm verschijnen:
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– Start de simulatie door op het 'play' icoon te klikken. De simulatie gaat nu starten en de 
robot gaat rijden. Je kunt instellen dat de camera meegaat met de robot door de robot in de 
3D view te selecteen en dan bijvoorbeeld  'View->Follow Object->Pan and Til shot' te 
kiezen.

– Als je een aanpassing maakt aan je simulatie code druk dan op de F7 toets om je code te 
compileren. Mogelijke foutmeldingen verschijnen onderaan in het Console venster.

– Zorg dat je de simulatie reset (terugspoelt) voordat je hem laat lopen zodat je altijd vanaf het
begin begint.

Andere robots, andere werelden
Binnen de webots omgeving zijn vele tientallen robots aanwezig die je kunt gebruiken in je eigen 
simulatie werelden. Ook kun je zelf een omgeving opbouwen en elementen uit andere simulaties 
gebruiken.
De voorbeeld webots projecten zijn te vinden onder 'Open Sample world...'.
Ook is het mogelijk om zelf een eigen project aan te maken via 'Wizards->New Projects 
Directory...' . Het is het handigst om een nieuw project onder je 'Documents\webots' hoofddirectory 
te plaatsen. 
Een nieuwe controller voor je eigen robot maak je aan met de 'Wizards->New Robot Controller...' 

De webots online documentatie
De webots documentatie is erg goed en gedetaileerd. Druk op de F1 toets in de webots omgeving en
je webbrowser opent met de 'Webots User Guide'.
Een lijst van de beschikbare robots is hierin ook te vinden op : 
https://cyberbotics.com/doc/guide/robots?version=R2021a
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Webots gebruiken met Visual Studio en de debugger
Voor het besturen van je robot kun je kiezen uit een aantal talen en daarbinnen weer voor het lokaal 
ontwikkelen binnen de webots omgeving of via Visual Studio. Die laatste optie heeft het voordeel 
dat je je simulatie in een debugger loopt en dat je dus het programma kunt stoppen en variabelen 
bekijken etc.
Visual studio is te downloaden op : https://visualstudio.microsoft.com/downloads/
Na installatie hiervan kun je binnen de webots omgeving een nieuwe controller voor je eigen robot 
aanmaken via de 'Wizards->New Robot Controller...'
Kies 'Next' en dan kun je de computer taal kiezen waarin je je robot controller wilt gaan 
ontwikkelen:

– Klik 'Next' en kies dan 'Microsoft Visual Studio'.
– Klik 'Next' en geef dan een naam in voor het bestand waarin je de controller code gaat 

schrijven voor je robot.
– Klik 'Next', je ziet nu het 'Conclusion' scherm.
– Klik op 'Finish'
– Visual Studio start nu op en laat de volgende boodschap zien:
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– Dit komt doordat we de nieuwste versie van Visual Studio gebruiken, dit is geen 
probleem. Klik op 'Ok'.

BELANGRIJK: om te zorgen dat je eigen robot ook echt met Visual Studio gaat werken moet je 
het veld 'controller' van je robot op '<extern>' zetten via de 'Select...' button:

Je eigen controller file vind je nu in Visual Studio in de 'Solution Explorer':
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Om je code te compileren druk je op F5. Zorg dat je in webots je simulatie hebt lopen door op de 
start simulatie button geklikt te hebben. De simulatie wacht dan op Visual Studio voordat die 
begint. Binnen Visual Studio kun je nu breakpoints zetten, variabelen bekijken etc. 

Tips en truuks

Onderdelen van andere simulaties copieren

Interessant is dat je elementen uit een andere webots simulaties kunt copieren naar je eigen 
simulatie. Dit kan door die simulatie in webots in te laden en dan op het betreffende element aan de 
linkerkant een copy te doen. Vervolgens laad je je eigen simulatie en voer je een paste uit.
De grafische elementen van dit element worden niet vanzelf meegenomen maar kun je daarna zelf 
van de betreffende directory copieren naar je eigen project. Vaak zit de grafische informatie in de 
textures subdirectory.

Een webots element in al zijn details zichtbaar maken

De elementen zoals robots, de vloer en dergelijke binnen webots laten standaard een overall view 
zien. Als je bijvoorbeeld 'DEF Linebot E-puck' van het lijnvolger voorbeeld openklapt dan zie je de 
overall attributen van de robot.
Als je een detail wilt aanpassen van een element dat niet zichtbaar is dan kun je het detail overzicht 
van het element activeren door:

– Klik met de rechter muis op het betreffende element.
– Kies de optie 'Convert to Base Node(s)'.
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Nu worden alle subonderdelen van het element getoond. Een belangrijk element is het 'children' 
element. Hieronder vind je alle subelementen die ook weer subelementen hebben. Zo zijn alle 
elementen van webot in een eigen boomstructuur opgebouwd.

Opmerkingen, vragen of suggesties
Mocht je een opmerking, vraag of een suggestie hebben over webots dan kun je die plaatsen op het 
HCC robotica forum : https://groups.google.com/g/hcc_robotmc

Veel plezier met het gebruik van de webots robot omgeving.

Rob van der Ouderaa (rouderaa@hccnet.nl)
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